NetBSD
Network
interface 확인
$ ifconfig -a wm0:
interface 에 맞게 (ex: wm0) 에 파일 생성
$ cat /etc/ifconfig.wm0 inet 192.168.187.230 netmask 255.255.255.0
라우팅 설정
$ cat /etc/mygate 192.168.187.2
DNS 설정
$ cat /etc/resolv.conf nameserver 192.168.187.2
network 서비스 시작
service network restart
Package
먼저 .profile 에서 PKG_PATH 환경 변수 설정
export PKG_PATH="http://cdn.NetBSD.org/pub/pkgsrc/packages/NetBSD/$(uname -p)/$(uname -r|cut -f '1 2' -d.|cut -f 1 -d_)/All"
BSD 계열에서 apt 나 yum 과 같은 역할을 하는 pkgin 설치(https://pkgin.net/)
pkg_add pkgin
이제 pkgin 으로 패키지 설치
pkgin install bash git vim stow sudo wget -y
GNU utils
pkgin install coreutils findutils
dotfile clone
$ git clone https://github.com/lesstif/dotfiles
shell 교체
$ which bash /usr/pkg/bin/bash
$ chsh
GNU utils sym link
git clone https://gist.github.com/lesstif/4217cd72e828020f823befef4da41a89